如何安装Yii2开源项目

从网上下载了Yii2开源项目yiichina/yii2-cmswskm/deruv,但是解压后却没有vender依赖目录,使用composer installcomposer update也不能将vender目录下载下来,会出现如图的错误(缺失图片):

解决方法:

1. 安装Composer Asset插件:

composer global require "fxp/composer-asset-plugin:^1.2.0"
或:
composer global require "fxp/composer-asset-plugin:*"

2. 在GitHub上新建一个Token,如下:

3. 重写运行composer install,并将复制的Token粘贴到位置,(不显示Token字符串),直接回车,等待几分钟,就完成了。